Problem
When using Rockwell Studio 5000, the connection to Allen-Bradley devices can be experienced as slow. This includes downloading changes to the device, viewing changes, and in general anything involving active communication with the device.
Cause
The time that it takes for a network packet to go from Studio 5000 to the Allen-Bradley device applies to every network packet that is being sent. The problem is that since Studio 5000 version 28 all network traffic is split into very small network packets, which means that a large amount of network packets need to be sent to complete the download. Even when the connection itself is fast, the overall download takes a long time due to the incredibly large amount of network packets and can thus be experienced as slow.
An easy comparison is to send 10 items via mail. If you send 1 item, wait for it to arrive at its destination, wait for a confirmation, then send item #2, wait for it to arrive at its destination, etc then it will take you a long time to send all 10 items. Sending multiple items at a time would be much faster.
Solution
Rockwell is aware of this issue affecting all remote connections and has implemented a solution in Studio 5000 version 34.
This version includes an improved architecture that improves the connection speed to devices. Note that updating your Studio 5000 version requires you to, during download, also update the firmware of your Allen-Bradley device. Please check the compatibility here before updating.
Additionally, other changes or settings may improve the connection speed as well. Please read Rockwell's full list of recommendations here.