Problem
A connection error occurs when using DirectSoft 6 to connect to an AutomationDirect DirectLogic PLC over VPN.
Cause
The connection times out because of network latency.
Solution
Increase the timeout setting in DirectSoft 6 from the default 25ms to 1000ms or higher.
- Open DirectSoft 6 and click on Connect.
- Either select an existing link that uses the TAP Adapter and press Edit, or add a new link and select the TAP adapter.
- Go to Port, select Ethernet and UDP/IP, enter the PLC's IP address, and press Advanced Settings.
- Change Timeout to 1000ms. If that doesn't resolve the issue, try a higher value.